#191343 gửi bởi phudq90
Ngày 05 Tháng 06 2019 , 13:33
Update: đã khắc phục được lỗi, set PHP version của hosting về 5.6 (site mình bị lỗi ở php 7.2).

-------

Site của em chỉ dùng module shops mặc định, thời gian gần đây bị lỗi trang trắng khi vào chi tiết 1 sản phẩm bất kỳ, các trang danh mục sản phẩm không bị, trang chủ cũng không bị.

Error_log:

[Thu, 06 Jun 2019 00:35:20 +0700] [42.116.121.151] [Run-time notices(8192): iconv_set_encoding(): Use of iconv.input_encoding is deprecated] [FILE: /includes/utf8/iconv_string_handler.php] [LINE: 15]
[Thu, 06 Jun 2019 00:35:20 +0700] [42.116.121.151] [Run-time notices(8192): iconv_set_encoding(): Use of iconv.internal_encoding is deprecated] [FILE: /includes/utf8/iconv_string_handler.php] [LINE: 16]
[Thu, 06 Jun 2019 00:35:20 +0700] [42.116.121.151] [Run-time notices(8192): iconv_set_encoding(): Use of iconv.output_encoding is deprecated] [FILE: /includes/utf8/iconv_string_handler.php] [LINE: 17]
[Thu, 06 Jun 2019 00:35:35 +0700] [42.116.121.151] [Error(1): Uncaught Error: [] operator not supported for strings in /home/tmcrackv/phukienturack.com/modules/shops/funcs/detail.php:196
Stack trace:
#0 /home/tmcrackv/phukienturack.com/index.php(273): require()
#1 {main}
thrown] [FILE: /modules/shops/funcs/detail.php] [LINE: 196]
[Thu, 06 Jun 2019 00:35:39 +0700] [42.116.121.151] [Warning(2): Use of undefined constant NV_BASE_SITEURL - assumed 'NV_BASE_SITEURL' (this will throw an Error in a future version of PHP)] [FILE: /includes/functions.php] [LINE: 1604]
[Thu, 06 Jun 2019 00:36:13 +0700] [42.116.121.151] [Run-time notices(8192): The each() function is deprecated. This message will be suppressed on further calls] [FILE: /modules/shops/admin/items.php] [LINE: 388]
Sửa lần cuối bởi phudq90 vào Ngày 09 Tháng 06 2019 , 13:36, với tổng số 1 lần sửa.
#191378 gửi bởi hoaquynhtim99
Ngày 09 Tháng 06 2019 , 06:42
Shop này có lẽ bản cũ, bạn cứ đưa về PHP 5.6 là chạy ổn vừa chạy được NukeViet 4.3 mà vừa chạy được shops cũ

Hãy sống là chính mình, bình thường nhưng không tầm thường.
#191379 gửi bởi phudq90
Ngày 09 Tháng 06 2019 , 07:03
Mình mới check lại thông số thì xin đính chính lại là mình đang chạy:
- Nuke 4.2.01
- Module shops 4.0.29
- PHP 7.2

Mình vừa set PHP version trên hosting thì kiểm tra thông tin trong nuke vẫn là 7.2, cho mình hỏi là set version xong thì khoảng bao lâu mới nhận diện version mới nhỉ? có apply ngay lập tức không ạ?
#191380 gửi bởi hoaquynhtim99
Ngày 09 Tháng 06 2019 , 08:03
NukeViet 4.2 thì php 5.6 cũng ok luôn bạn.
Theo mình thấy thường thì các hosting set version thì ngay lập tức được luôn

Hãy sống là chính mình, bình thường nhưng không tầm thường.
#191381 gửi bởi phudq90
Ngày 09 Tháng 06 2019 , 13:26
UPDATE: đã khắc phục được, vào Select PHP version là enable các option có tên pdo lên là ok.

-------------------

Mình mới nhờ hosting support set PHP xuống 5.6 thì vô trang chủ bị lỗi trắng luôn :(

Check error log:
 [Mon, 10 Jun 2019 00:20:48 +0700] [42.116.101.250] [Error(1): Class 'PDO' not found] [FILE: /vendor/vinades/nukeviet/Core/Database.php] [LINE: 20]
Sửa lần cuối bởi phudq90 vào Ngày 09 Tháng 06 2019 , 13:35, với tổng số 1 lần sửa.