Nội quy chuyên mục: - Khu vực này chỉ dành cho việc thảo luận phát triển các Module, block, theme và các tính năng mới cho hệ thống.
- Tên topic chính là tên Block, Module, Theme. Không được đặt tên Block, Module, Theme trùng với Block, Module, Theme đã có.
- Các thảo luận cho Module, block, theme nào phải được gửi ngay tại topic mà người đầu tiên gửi nó lên.
- Vui lòng không gửi câu hỏi và các yêu cầu trợ giúp tại đây. Topic vi phạm nội quy sẽ bị xóa ngay lập tức!
#139925 gửi bởi phuctd
Ngày 26 Tháng 06 2013 , 22:02
Em có đoạn code sau:
Mã: Chọn hết
$contents .= "<div id=\"content\"><form id=\"form1\" name=\"form1\" method=\"post\" autocomplete=\"off\" action=\"" . NV_BASE_SITEURL . "index.php?" . NV_LANG_VARIABLE . "=" . NV_LANG_DATA . "&" . NV_NAME_VARIABLE . "=" . $module_name."\">\n";
$contents .= "<table width=\"100%\" border=\"0\" bgcolor=\"#f7f7f7\" class=\"tab1\">\n";
$contents .= "<tr>\n";
$contents .= "<td width=\"430\" rowspan=\"3\" align=\"center\" valign=\"top\">
<img src=\"" . NV_BASE_SITEURL . "" .$folder_pic. "" .$thumuc. "/" .$mang[$k]."\"
height=\"600\" width=\"430\" /></a></td>\n";


Ở localhost, ảnh tại thẻ <img ... hoạt động bình thường. Nhưng khi đưa lên host, hệ thống không hiển thị ảnh, nguyên nhân là biến NV_BASE_SITEURL không có giá trị. Mâu thuẩn là giá trị NV_BASE_SITEURL tại action của thẻ <form... ở trên lại có giá trị. Mong các bác chỉ giáo.
#139926 gửi bởi convoi
Ngày 26 Tháng 06 2013 , 22:24
Bạn cho xin cái hình kết quả hiển thị trên web mà code trên thể hiện.

Đối với hình ảnh có thể bạn nên dùng cấu trúc thư mục NV_ROOTDIR. Hoặc thử dùng NV_MY_DOMAIN . NV_BASE_SITEURL

Con Voi